Kamis, 16 Maret 2017

Under Construction

site underconstuction

goal implementing boostrap in blogspot 

will be back writing when finish.

Sabtu, 18 Februari 2017

Example Connect GNS3 RouterOS_CHR from an Outside world



Example Connect GNS3 RouterOS_CHR  from an Outside world
I mean Not The Internet already done that in the first post.
what  I mean Client Connect to RouterOS_CHR hostspot via access point
to simulate login page with your android or laptop

 Tools we need
Accesspoint  real one not virtualize, connect it to LAN

NOTE: before we go Router_OS must already configure as hotspot.
from gns3 UI select Switch and Cloud drag it to GNS3 Canvas
Cloud1 = connect to VirtualBox host adapter
Cloud2 = connect to LAN adapter. LAN adapter connected to Access Point Outside world

NOTE to connect To router OS, LAN IP address adapter must be configure Static and 
           set the gateway to hotspot address. 
if setting correct we will the address of accesspoint in dhcp server 
read the active host name, I use TP-LINK TL-WA901ND as an accesspoint.
every device connected to TP-LINK will meet the login page.

now we gain free Mikrotik but better to buy RB.
production cost cheaper than using PC.
also note Router_OS free limit device speed only 1Mbps.
done..


Jumat, 17 Februari 2017

Add Admin Support Chat To Our Website, Blog etc..


Add Admin Support Chat To Our Website, Blog etc..
also can be use on Mikrotik Hotspot page.

it might be not very usefull to add this to our website but 
it make our site more cool  hahaha..

to add chat service to our site, we can use free chat service like on my blog i use tawk.to 
first thing first create tawk.to account go to their website create a free account





fill name, email, and password click sign up button.
after complete the registration we will recieve an activation email. klik the activation email than done.

login to tawk.to with newly created account. after login we will be redirect to dashboard
go admin tab select all the widget code and copy it.

go to our website. search for closing body tag (</body>) paste the code before it.
now we've done. 
simple fast and easier.

to customize appearance go to admin tab on tawk.to dashboard. 
select widget appearance customize it as we want.

For blog we can edit html template and add the script 

for mikrotik login page
we had 2 option

first one we only give support admin chat to voucher that already login.
in this option user can only chat with admin in status page. so we put the script before the closing body (</body) of status page mikrotik.

second option we give all support admin to everyone connected to our hotspot.
we need to edit 3 page, login, status and logout page. add the script to each page.
when done we need to allow access to tawk.to website 

paste this code below to terminal
         /ip hotspot walled-garden add dst-host=*tawk.to dst-port=443

done

try to access the login page see if that script works.

got trouble ask me, i might can help.



Trick Sederhana Membagi Rata Bandwidth ke Client Di Mikrotik


Trick Sederhana Membagi Rata Bandwidth ke Client 

Di Mikrotik


Catatan: settingan ini hanya untuk hotspot bukan untuk game online
cara kerjanya membagi bandwidth rata ke semua client yg aktif.
semua bandwidth pasti kepakai.





 


Queue Treenya:
             Catatan: setingan ini defaultnya untuk kecepatan 10Mbps
 
/queue tree
add name=HTTP parent=global priority=5 queue=pcq-download-default
add name=ICMP packet-mark=icmp_pkt parent=global priority=1 queue=\
    pcq-download-default
add max-limit=1560k name=UPLOAD packet-mark=up_pkt parent=global queue=\
    pcq-upload-default
add limit-at=5M max-limit=10M name=HTTP-SMALL packet-mark=small_pkt parent=TCP \
    priority=6 queue=pcq-download-default
add limit-at=5M max-limit=10M name=HTTP-BIG packet-mark=big_pkt parent=TCP \
    priority=7 queue=pcq-download-default

copas aja ke terminal,

buka speedtest.net dulu, uji kecepatan jaringan 

Gambar diatas kecepatannya Download 10.51Mbps Upload 1.63Mbps
tinggal lakukan penyesuaian di queuetree
ambil angka aman saja Download 10Mbps Upload 1.5Mbps.

tinggal sesuaikan

Speed 10Mbps Download / 1,5Mbps Upload
HTTP-SMALL limit-at=5M max-limit=10M
HTTP-BIG limit-at=5M max-limit=10M
UPLOAD max-limit=1560k

Speed 1Mbps Download / 512k Upload
HTTP-SMALL limit-at=512k max-limit=1M
HTTP-BIG limit-at=512k max-limit=1M
UPLOAD max-limit=512k

kurang jelas tanya saja.

Kamis, 16 Februari 2017

GNS3 Virtual Lab Mikrotik example

GNS3

Virtual Lab Mikrotik


example
Recomended Using Oracle Virtual BOX, Qemu failed with memory management result os so lag. don't wanna use it again. virtual box win in performance.

My System
A68N-5000
4GB memory
Windows 10 Pro 32 Bit
low spek but run smooth with Virtual BOX

First Thing Oracle Virtual BOX

GNS3 
hosted by github so we might need to create an account before download it.

Windows
last part mikrotik chr
extra package for usermanager etc.
extra package 6.38.1
Note: x86 not support IP Cloud yet. so we can't use it.

we will need to install all of it some might be need to download automatically while install like wireshark etc.

NOTE:  vdi chr image only run on virtual box with linux 64 bit with KVM acceleration
so make sure we choose linux other 64 bit and set the VM acceleration to KVM


NOTE: Make sure to share internet adapter with Virtual Box Adapter, this will allow Mikrotik to gain internet access / also using it to access mikrotik from VM host.
  
Last preparation we need create windows 7 image in virtual box
we can use any os (linux, windows 8, XP, x86 Android etc.) this only to virtualize client access to mikrotik.
when done. shut it down.
NOTE: gns3 only detect VirtualBox Image if we already run it at least one time.

everything set its time to make the lab.

1. run the GNS3 app, in user interface go to edit-preference (crtl+shift+p)

 on server tab make sure local server enable
go to VirtualBox VMs
select new button choose RouterOS_CHR create earlier from dropdown menu.
Note: if not listed than we might need to run it manually from VirtualBox UI for the first time.
in GNS3 1.5 or 64 bit system make sure change it from ENDDEVICE to ROUTER. but in GNS3 1.3 for windows 32 bit no option for that. alternative we can only change the picture to router. but still won't listed in router device on GNS3 UI.

Virtual Box only support 4 LAN Adapter, we can set it more than 4 but it will loop the adapter and confusing us because only one adapter active on mikrotik. virtual box share ether1 with ether5, ether2 with ether6 so on, so for this only limit maximum adapter to 4 only.
Note: make sure to tick Allow GNS3 use any configured VirtualBox Adapter

Do it again with windows7 image create earlier.
  so we have to virtualbox image one Routeros_chr and second windows7 image.
save all the change

2. Draw the network topology in gns3 Canvas.
select browse all device button from gns3 UI. drag Cloud, Hub or Switch, RouterOS_CHR, and Windows 7 Image from listed device to GNS canvas

configure the Cloud to select VirtualBox host only Adapter than click add button. this will connect GNS3 to outside (internet and the Host).


connect all the device in canvas by drawing a line.
select link button
draw line from windows 7 to Router_os chr ether2
draw line from RouterOS CHR ether1 to hub/switch ether1
draw line from hub/switch ether2 to Cloud.



3. Run the GNS3
now we've done try run it. by pressing start button on GNS3 UI.
 
Troubleshoot:
1. No User Interface VirtualBox display.
            right click vbox image on gns3 canvas select configure-> select the image-> 
            untick start VM in headless mode.
2. RouterOS CHR cant get ip address
           make sure to share the internet adapter with virtual box host only adapter
3. No internet Access
          Route on mikrotik haven't set yet. or internet adapter not sharing haven't set yet
 4. can't access via winbox
          login to mikrotik box on virtual box, /ip address print. check if mikrotik get the ip from 
         dhcp server use that ip to remote mikrotik.
         NOTE: ether1 ip must be the same subnet with dhcp server windows 
                      default value 192.168.137.1/24.

any other troubleshot ask me, will try to answer it.

Rabu, 15 Februari 2017

AMD Crimson Driver 16.12.2


AMD Crimson Driver 16.12.2

 Buat PC gaming VGA AMD menggunakan Catalist Driver dapat meningkatkan performa Gaming atau bisa juga digunakan untuk pelengkap driver yang tidak tercover driver pack







 Download 

Driver Pack 17.7.33


Driver Pack 17.7.33



 Driverpack Solution
Cover hampir semua driver masih gak lengkap perlu tambahan manual install untuk beberapa driver.
Link hanya host di tempat lain yg ini hanya untuk backup pribadi.

Kalau butuh silahkan download.